Die Pflege der PHP-Version 5.4 wurde am 3. September 2015 eingestellt. Aktuell sind die Versionen 5.5 und 5.6, die Sicherheitsaktualisierungen bis 2016-07-10 bzw. 2017-08-28 erhalten.

In Oldstable-Debian 7 »Wheezy« wird nur PHP 5.4 mitgeliefert. Man bemüht sich zwar, nötige Sicherheitsaktualisierungen wenn möglich nachzuliefern,

PHP 5.4 has reached end-of-life on 14 Sep 2015 and as a result there will be no more new upstream releases. The security support of PHP 5.4 in Debian will be best effort only and you are strongly advised to upgrade to latest stable Debian release that includes PHP 5.6 that will reach end of security support on 28 Aug 2017.

aber man soll seine Systeme besser auf das derzeitige Stable Debian 8 »Jessie« aktualisieren, welches PHP 5.6 mitbringt.

Jedoch ist es nicht in allen Fällen möglich, schnell auf »Jessie« umzusteigen. Es mag gute Gründe geben, das Oldstable-System »Wheezy« noch bis zu seinem offiziellen Lebensende im Februar 2016, vielleicht sogar noch länger im Long Term Support (der allerdings nur einen kleinen Teil der Pakete unterstützt und wahrscheinlich auch nicht PHP – so war es jedenfalls bei Debian 6 »Squeeze« LTS) bis Mai 2018 zu betreiben.

Moderne Webanwendungen setzen allerdings gelegentlich schon PHP in Versionen ab 5.5 voraus. Zum Beispiel das kommende Drupal 8 benötigt PHP mindestens in Version 5.5.9, besser in 5.5.21 oder 5.6.5. Mit PHP Version 5.4 aus Debian 7 läßt es sich nicht installieren:

Your PHP installation is too old. Drupal requires at least PHP 5.5.9. See the system requirements page for more information.

Auch WordPress empfiehlt PHP 5.6.

Dotdeb zur Rettung

Bei Dotdeb gibt es PHP 5.5 und 5.6 und andere Software (Redis, Zabbix, MySQL, Nginx) in recht aktuellen Versionen für Debian 6 »Squeeze«, Debian 7 »Wheezy« und Debian 8 »Jessie« für i386 und amd64. Sofern man Dotdeb für vertrauenswürdig und sicher hält, kann man es als Paketquellen hinzufügen. Beispielsweise für PHP 5.6 für Debian 7:

cat << EOF | sudo tee /etc/apt/sources.list.d/dotdeb.list
deb http://packages.dotdeb.org wheezy all
deb-src http://packages.dotdeb.org wheezy all

deb http://packages.dotdeb.org wheezy-php56 all
deb-src http://packages.dotdeb.org wheezy-php56 all
EOF

Es gibt einige Spiegelserver für Dotdeb, von denen man sich vielleicht einen nahegelegenen aussuchen möchte.

Den öffentlichen PGP-Schlüssel von Dotdeb hinzufügen, damit zukünftig Pakete auf Echtheit geprüft und installiert werden können:

wget -O - https://www.dotdeb.org/dotdeb.gpg | sudo apt-key add -

Die neuen Paketquellen einlesen:

sudo aptitude update

Spätestens jetzt sollte eine Datensicherung der PHP-Konfiguration in /etc/php5/ durchgeführt werden.

Die PHP-Pakete (gegebenenfalls die benötigten für das lokale System anpassen) neu installieren, um die von Dotdeb zu verwenden:

sudo aptitude install php5 php5-cli php5-fpm php5-gd php5-mysql php-apc-

Der Alternate PHP Cache (APC) wird entfernt (das Minus hinter php-apc- beachten), da es mit neuen PHP-Versionen nicht mehr kompatibel ist. In PHP 5.5 wurde Zend OPcache integriert. Gegebenenfalls noch php5-apcu (APC User Cache) aus Dotdeb nachinstallieren, wenn man mehr der früheren APC-Funktionalität als den Opcode-Cache benötigt, die der integrierte OPcache nicht bietet, nämlichen den Datencache im Speicher.

Falls man eigene PHP-Konfigurationen vorgenommen hatte, muß man die möglicherweise wieder aktivieren. Hat man etwa eine /etc/php5/mods-available/local.ini, so muß man wieder sudo php5enmod local ausführen und bei der Verwendung des Fast Process Managers (FPM) ihn mit sudo service php5-fpm reload neu laden.

Besser Debian 8 »Jessie« mit PHP 5.6

Am besten ist es jedoch, wenn man vom Oldstable Debian 7 »Wheezy« auf das aktuelle Stable Debian 8 »Jessie« aktualisiert. Dort wird das PHP 5.6 aktiv gepflegt und auch das Sicherheitsteam kümmert sich darum – das ist dann das offizielle, vertrauenswürdige, stabile Debian.